Fixing Wifi Connection Issue after Windows Creators Update

For those having Wifi issues after the update to Creators edition, please use the following steps to resolve the issue.

In the search box on the taskbar, type Device Manager, and then select Device Manager from the list of results.

In Device Manager, select Network adapters > the network adapter name.

Press and hold (or right-click) the network adapter, and then select Properties.

In Properties, select the Driver tab, select Roll Back Driver, then follow the steps.


After rolling back to the previous version of the driver, select the Start button > Power > Restart. After the restart your wifi should be working again.

1 person likes this

I tried the Broadcom device rollback for my new Protocol X8, but that option was "greyed out" and thus unavailable.  The tablet had Internet before the updates were installed, but is now unuseable on the Internet.  Am I out of options?  

Wow so your keyboard is not paired... sounds like all your wireless is messed up.

So get an OTG cable and add a USB hub to it so you can run a usb keyboard and also have the usb memory stick?

You need a computer buddy it seems like. How much effort is it worth to you? Enough to understand drivers? If it was mine, clearly the shortest path is to repair the issues you have, since even a clean install will take longer in updates.

Is it worth all this effort?



I do not have a USB keyboard. I'll have to ask around. I understand enough of what I'm doing messing with drivers. And in the prompt I just enter what's instructed. Although some posters for some reason often give bad commands. Earlier on in this quest one ID TEN T actually said type " select disk E" when it's just :E. So you can see that I'm determined to fix this. I've tried many methods and repeated them. The test mode is new to me. Too bad it didn't work. Also FYI I did try to reset but after two tried, it wouldn't do it. It's like it hates me. Already it only has one measly port so you can't charge it and do anything else at the same time. I have a USB adapter and when plugged into other THAT works. But only on battery. Anyway that's enough for today I'll be back for more punishment tomorrow though. Thanks.

It is critical to ensure there are zero issues with the remote system related equipment. You have to check the equipment first on the off chance that you dawdle on different futile Windows designs or activities on your Windows 10 Fall Creators Update/Creators Update PC and another information if you need any types of information and fixes then you should visit us on the how to connect Telstra Wifi.

By the way, my Protocol X8 is currently running Win 10 Professional version 1903 build 18362.10014. It's been one of the most compatible tablet computers in the inexpensive category I have had.

This is actually the Windows Insider slow ring, a step beyond the stock releases.

If anyone is having issues, I'll be happy to share the driver versions I am using.

It's running perfectly.


ok we had the same problem with ours  too... but the sound  has a red mark next to it... any  help  for  sound?

will the  next time i  look  for updates eat driver again

yep get the sound driver too..



Yep   did  so and all is  well now!  I  just  hope the next update  does not put the evil drivers back!


Guess he gave up... 

Download the drivers from the solutions page.  Unzip and transfer drivers via USB to the tablet.  Use the Update Drivers and select Browse My Computer for Drivers.  Select the location you transferred the drivers to and then click Let Me Pick From a List.  Select the driver dated 7/9.2015.

After the driver is installed, your WiFi should work again. 


Thank you once again.

Login or Signup to post a comment