Fixing Wifi Connection Issue after Windows Creators Update

For those having Wifi issues after the update to Creators edition, please use the following steps to resolve the issue.

In the search box on the taskbar, type Device Manager, and then select Device Manager from the list of results.

In Device Manager, select Network adapters > the network adapter name.

Press and hold (or right-click) the network adapter, and then select Properties.

In Properties, select the Driver tab, select Roll Back Driver, then follow the steps.


After rolling back to the previous version of the driver, select the Start button > Power > Restart. After the restart your wifi should be working again.

1 person likes this

By the way, my Protocol X8 is currently running Win 10 Professional version 1903 build 18362.10014. It's been one of the most compatible tablet computers in the inexpensive category I have had.

This is actually the Windows Insider slow ring, a step beyond the stock releases.

If anyone is having issues, I'll be happy to share the driver versions I am using.

It's running perfectly.


I was referring to the versions of the device drivers, which should have solved your issues, going through them one by one would have solved the issues.

When I tried to take you in that direction I got this:

"Sorry but I don't know what to do with that information. My virtual adapter isn't even showing now. Even if it did it would have the yellow triangle. I've attached shots of my device mgr and wifi fail. This is a protocol x8. I really don't know about GPIO or where to get them or what to do with them Basically I have no idea what you are telling me. Sorry"

So I was trying to tell you that there are other drivers that are necessary to even SEE the hardware, that was your issue, these other drivers work with the hardware to communicate to other devices, the GPIO and LPC and other controller drivers are the interface to things like WiFi.

Then you state: " I understand enough of what I'm doing messing with drivers. And in the prompt I just enter what's instructed."

Clearly you don't understand at all, understanding drivers is quite a bit more than just hitting enter or next.

But like I said, if you did not understand that there are other drivers involved (not just the wifi driver) then a clean install is best.

The fact you tried to load the operating system mainly because your wireless is not working, which means clearly your wireless bluetooth keyboard would also not work, and you did not get a USB keyboard with a touchpad/mouse emulator sounds like trouble brewing.

In any case, are you going to keep trying or are you giving up? I guess you did not completely understand my offer about low cost shipping? That was an offer to fix it for you... free...

Greg (the dick)

you know that was completely unnecessary what you just said I did try every one of those things and then when I when you didn't work I replied I don't know how what you were reading or what I was writing that made you think that but you were just being a dick that's not cool anyway it doesn't work I can't fix it it won't even let it won't even recognize the thumb drive in there and everything and I'm tell goodbye oh and I was using the voice thing that's why some of it doesn't make sense

You know you came here for advice but basically took none of it. And here I am with one working perfectly and having the details to help you specifically, but you insisted on a different course and now you have the BSOD.

In fact mine is on the Insider program with an advanced copy of Windows, and of the 5 computers I have with an Atom chipset, this one is the least trouble.

Don't know what to say except tried to help you and you ignored advice. You claimed to be knowledgeable but I gave you some of the most basic information on drivers and you said "I don't know what to do with that information", even getting a USB keyboard seemed to be a big deal.

When I don't understand something, I listen to an expert, or at least someone that knows more than me. I tried and my help was basically rejected.

Last chance: are you in the USA? Can you ship by USPS cheap? One last offer to help, although this computer is only worth about $50 on the open market.


I resigned to just installing the driver every time I turned it on and only use the on screen keyboard... And then I tried the image reinstall again after a couple of days... Now it's stuck in a never-ending loop of BSOD and then diagnosis and on and on For all the man hours I put in, I would have easily earned enough to buy another one, I'm sorry to say I won't be return for a Hyundai.

Guess he gave up... 

I do not have a USB keyboard. I'll have to ask around. I understand enough of what I'm doing messing with drivers. And in the prompt I just enter what's instructed. Although some posters for some reason often give bad commands. Earlier on in this quest one ID TEN T actually said type " select disk E" when it's just :E. So you can see that I'm determined to fix this. I've tried many methods and repeated them. The test mode is new to me. Too bad it didn't work. Also FYI I did try to reset but after two tried, it wouldn't do it. It's like it hates me. Already it only has one measly port so you can't charge it and do anything else at the same time. I have a USB adapter and when plugged into other THAT works. But only on battery. Anyway that's enough for today I'll be back for more punishment tomorrow though. Thanks.

Wow so your keyboard is not paired... sounds like all your wireless is messed up.

So get an OTG cable and add a USB hub to it so you can run a usb keyboard and also have the usb memory stick?

You need a computer buddy it seems like. How much effort is it worth to you? Enough to understand drivers? If it was mine, clearly the shortest path is to repair the issues you have, since even a clean install will take longer in updates.

Is it worth all this effort?



Okay so Hyundai offers an image for Windows 1703. It gets complicated and you have to make a USB for it. They should have an option to make it on a micro SD card since it has the port. But it also needs a USB keyboard which I don't have. I'm working on another thread. If any more specific problems come from that I may ask here. But wait there's more. I can't connect to the keyboard that come s with the protocol. It only shows unknowns. Sometimes it shows a keyboard ready to pair but like all the unknowns it says "that didn't work" I did the usual and uninstalled and reinstalled driver. Then I tried same with driver from the downloaded driver pack from Hyundai site. That didn't work either, even in test mode in hopes that letting any driver be installed, not exclusively Microsoft drivers. I know that's not this thread. But I'm not sure how to start one.

Sorry, you indicate you are at device manager, but I guess you have not hit the tab to look at the driver and the driver version for devices.

So, I gave you several devices and driver versions that would be seen in device manager.

If you are already in device manager and and the data I gave you does not make sense, then you should probably be looking to just reload the whole operating system, rather than debug which devices/drivers need to be changed/updated.

Yes I have an X8, and it is running great on Windows 10 Pro, build 1903.

I could give you a path to fix your issues, but it would take finding and installing drivers for the devices you are seeing.

Unfortunately, when you reload the operating system, unless you block updates, this will probably happen to you again. Be sure to stop updates after you reload, and then back up your system between updates.


Sorry but I don't know what to do with that information. My virtual adapter isn't even showing now. Even if it did it would have the yellow triangle. I've attached shots of my device mgr and wifi fail. This is a protocol x8. I really don't know about GPIO or where to get them or what to do with them Basically I have no idea what you are telling me. Sorry

 Mine is working fine, you have a driver mismatch somewhere.

The wifi driver is Broadcom

The other drivers are likewise important:

The GPIO virtual controller is Intel 604.10135.1000.55535

The I2C controller is Intel 604.10143.1010.2069

The GPIO controller is Inter 604.10135.1010.53001

Those are the most important ones I have found.


i'm going to try the flash for windows 1703 image recovery

I have no confidence since everything thus far has failed.even Ron Kuzma in above comments said he had a clean install of windows and still couldn't get wifi

I'l post my results

I have the same problem with my protocal8 and I fixed the missing msvcr120.dll file

and I installed the drivers recommended - bcmdh64 and bbcmfn2

Still not working - it recognizes available wi fi after I uninstall broadcom adapter and then scan for hardware changes every time.  BUT it always says can't connect to this network. I tried it at home and at starbucks while my phone had no problem connecting.

and it always has a yellow triangle for the virtual adapter (which isn't even there half the time).

When i restart, the wifi once again has the red asterisk.


RE Network:   Hardware ID  SD\VID_02D0&PID_A94D&FN_1

When in device manager and running  update driver - have disk,  both bbcmfn2 and bcmdh64 creates error message , location does not contain a compatible software driver.

When I right click, install  bcmdh64 directly fron unziped file, program returns a message installed successfully.

When I right click, install  bbcmfn2  directly fron unzipped file, program does not return any message regarding  completion.

Same results with Broadcom  801 adapter installed , disabled or uninstalled.

I ran Bcmwlanappe.exe from wifi unzipped folder and it returns  message , cannot proceed because  MSVCR120.dll was not found.

Cannot find driver match at

Unknown Device   hardware IDs   ACPI\VEN_KIOX&DEV_000A    ACPI\KIOX000A   KIOX00A

Drivers for this device are not installed   Code 28.   There are no compatible drivers for this Device

Touch Screen is not working.

Recap :  Network still not working, device manager yellow caution network adapter: Broadcom 802.11abgn wireless SDIO Adapter

OtherDevices, device manager yellow caution unknown device  Drivers for this device are not installed .  Hardware IDs ACPI\VEN_KIOX&DEV_000A    ACPI\KIOX000A   KIOX00A

System Devices    BCMFN2   device manager yellow caution code 51  waiting on other devise, the Network Adapter noted above, SD\VID_02D0&PID_A94D&FN_1

Touch Screen is not working.

Login or Signup to post a comment